linux上编译安装swoole

简介安装swoole


检查依赖环境


1:    php7以上版本

2:    gcc4.4以上版本

yum install -y gcc-g++

3:php开发包

image.png


    4: cmake2.4以上版本

    yum install -y cmake




1.下载swoole压缩包

我这里从github下载最新的版本,执行下面的命令

wget https://github.com/swoole/swoole-src/archive/v4.5.2.tar.gz


2.解压压缩包

tar -zxvf  v4.5.2.tar.gz


3.进入解压后的文件夹

cd swoole-src-4.5.2


4.使用phpize命令产生出configure可执行文件,没有phpize请自行安装

phpize


5.开始进行配置

./configure --enable-http2 --enable-openssl  --with-php-config=/www/server/php/73/bin/php-config


6.make

make && make install


7.make结果如下

1593831644(1).jpg


8.最后将找到你的php.ini文件 将extension = swoole.so复制进去运行 php-m,则能成功看到你安装的swoole扩展

1593832116(1).jpg

 

文章评论

    2020-09-17haosucai

    老兄 老吊

共有1条评论来说两句吧...

用户名:

验证码:

Top